Long response times
Incident Report for Planday
Resolved
All Planday accounts should be up and running again now. Thanks for being patient with us.
Posted Oct 28, 2019 - 16:34 CET
Update
We are continuing to investigate this issue.
Posted Oct 28, 2019 - 16:15 CET
Investigating
It seems some Planday accounts aren’t loading properly. Apologies for any problems this causes you — we are working hard to resolve it. We will let you know when it’s fixed. Thanks for your patience!
Posted Oct 28, 2019 - 16:08 CET
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App) and Planday Web, Punch Clock, API.