Degraded performance on some parts of the product

Incident Report for Planday

Resolved

This incident has been resolved.
Posted May 13, 2024 - 10:15 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2024 - 09:53 CEST

Investigating

We’re sorry to report that some customers might experience slower loading times.
Our team is working on identifying the root cause.
We apologize for the inconveniences and will update you as events warrant.
Posted May 13, 2024 - 09:30 CEST