Degraded performance affecting Mobile App and Web
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Jan 22, 2019 - 16:23 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 22, 2019 - 16:12 CET
This incident affected: Web, Punch Clock, Mobile App - iOS, Mobile App - Android, and Mobile Kiosk App.