Issues with Planday's help centre
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Nov 21, 2020 - 12:53 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2020 - 12:24 CET
Investigating
Our help centre may not be accessible for some users on Web/Mobile.
We are currently investigating the issue.
In the meantime, you can access the help centre via https://intercom.help/planday/
Posted Nov 21, 2020 - 12:18 CET