Portal Schedule gives timeout error for some customers
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 10 days ago. Sep 10, 2019 - 15:18 CEST
Investigating
We are currently investigating this issue.
Posted 10 days ago. Sep 10, 2019 - 15:03 CEST
This incident affected: Planday Web.