Login issues
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 8 days ago. Aug 15, 2019 - 09:20 CEST
Investigating
We’re sorry to report that some users are unable to log in to Planday. We’re investigating this issue now and will report back when it’s fixed. Thanks for your patience.
Posted 8 days ago. Aug 15, 2019 - 09:15 CEST
This incident affected: Planday Web.