Problems loading some accounts

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 15:57 CET

Monitoring

The team has implemented a fix and we can see improved performance. We are monitoring the results.
Posted Nov 03, 2025 - 15:40 CET

Investigating

Some customers may currently be experiencing degraded performance on some parts of the product.
The team is currently investigating the issue.

We will send an additional update in 30 minutes or as events warrant.
Posted Nov 03, 2025 - 14:54 CET
This incident affected: Web.