Problems loading some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 16:22 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2019 - 16:12 CEST
Update
We are continuing to investigate this issue.
Posted Oct 21, 2019 - 16:04 CEST
Investigating
We’re sorry everyone, it seems some Planday accounts aren’t loading properly. Apologies for any problems this causes you — we are working hard to resolve it. We will let you know when it’s fixed. Thanks for your patience!
Posted Oct 21, 2019 - 16:04 CEST
This incident affected: Planday Web and Punch Clock.