UK customers might experience longer response times
Incident Report for Planday
Resolved
The issue have been resolved, but we will continue monitoring.
Posted Dec 06, 2018 - 19:02 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2018 - 18:53 CET
Investigating
Our UK customers might experience longer response times on the mobile app, web and punch clock.
We are currently investigating the issue and will post an update as soon as possible.
Posted Dec 06, 2018 - 18:36 CET
This incident affected: Web, Punch Clock, and Mobile App - iOS.