Service disruption

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 17:00 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2025 - 16:38 CEST

Investigating

A number of our users currently experience intermittent loading issues.
Our team is investigating the issue and we will provide an update within 30 minutes.
Posted Aug 18, 2025 - 16:26 CEST
This incident affected: Web, Mobile App - iOS, and Mobile App - Android.