Text-, email messages and mobile notifications can be delayed for some Planday accounts due to Third-party incident
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 15:03 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2020 - 14:50 CET
Investigating
Some Planday users can experience delay in reception of text-, email messages and mobile notifications.
Our team is investigating the issue.
Posted Mar 16, 2020 - 12:29 CET