Degraded performance in some parts of our product - Particularly on Payroll export

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 17:05 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2026 - 16:41 CEST

Identified

We have reports of some customers experiencing issues in some parts of our product, particularly the payroll export page. The team has identified the issue and is working on a fix. We will update as events warrant.
Posted Aug 06, 2026 - 15:36 CEST
This incident affected: Web.