Log in issues
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 14:03 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2020 - 13:01 CET
Investigating
We’re sorry to report that some users are currently unable to log into Planday.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 20 minutes.
Posted Nov 18, 2020 - 12:54 CET
This incident affected: Planday Web, Punch Clock and Mobile App (Mobile App - iOS, Mobile App - Android, Kiosk App).