Degraded performance for all accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 12, 2019 - 14:35 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 12, 2019 - 13:57 CEST
Investigating
Some Planday accounts are experiencing degraded performance at the moment.
Please bear with us whilst we investigate the issue.
Posted 4 months ago. Jun 12, 2019 - 13:46 CEST
This incident affected: Planday Web.