Planday mobile app incident
Incident Report for Planday
Resolved
This incident has been resolved.
Posted May 11, 2020 - 17:00 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2020 - 16:22 CEST
Investigating
We currently have issues with the Planday mobile app.
Our team is investigating and we will update this page within an hour or as events warrant.
In the meantime, please use Planday's web version.
Posted May 11, 2020 - 15:38 CEST
This incident affected: Mobile App (Mobile App - iOS, Mobile App - Android).