We are continuing to monitor for any further issues.
Posted Sep 22, 2025 - 15:05 CEST
Monitoring
Performance has improved in the pages affected: Schedule, Reports, People. We'll continue to monitor. We'll update within the next hour.
Posted Sep 22, 2025 - 15:03 CEST
Identified
We've identified the issue and we've implemented a fix for it. We're seeing improvements in the Schedule, People and reports pages. We're monitoring and we'll update within the next 30 minutes or as events warrant.
Posted Sep 22, 2025 - 14:26 CEST
Update
We are continuing to investigate the issue. We see degraded performance on most portals, particularly on pages such as Schedule, Reports, Payroll. We weill update within an hour or as events warrant.
Posted Sep 22, 2025 - 14:05 CEST
Investigating
We are currently investigating reports of degraded performance on some portals, particularly some pages in settings. We will update in 30 min or as events warrant.