Reporting data may show stale data
Incident Report for Planday
Resolved
Reporting data is now up to date again.
Posted 2 months ago. May 07, 2019 - 14:48 CEST
Identified
We are right now seeing delays to data processing for some of our reports. We are working on providing an ETA on a fix.
Posted 2 months ago. May 07, 2019 - 14:36 CEST
This incident affected: Planday Web.