Problems loading some accounts
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 11:31 CET
Investigating
We’re sorry everyone, it seems some Planday accounts are getting an error message after login on the web application. Apologies for any problems this causes you — we are working hard to resolve it. We will let you know when it’s fixed. Thanks for your patience!
Posted Nov 05, 2019 - 11:31 CET
This incident affected: Planday Web.