Slow response time for some Planday accounts

Incident Report for Planday

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 15:01 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 14:16 CET

Investigating

Some Planday accounts may experience slower loading times on certain pages.
Our team is actively working to identify the root cause.
We will post an additional update in 30 minutes or as events warrant.
Posted Oct 29, 2025 - 14:08 CET
This incident affected: Web, Punch Clock, Mobile App - iOS, Mobile App - Android, Mobile Kiosk App, and Open API.