Service Disruption
Incident Report for Planday
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 14:21 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2021 - 13:41 CEST
Investigating
We are currently experiencing a service disruption.

Our team is working to identify the root cause and we will send an additional update in 20 minutes.
Posted Apr 29, 2021 - 13:32 CEST
This incident affected: Planday Web.