Problems loading some areas of Planday
Incident Report for Planday
Resolved
Good news: The issue has been resolved.
We appreciate your patience with us on this.
Posted Jan 08, 2020 - 23:27 CET
Investigating
We’re sorry everyone, it seems Planday accounts aren’t loading properly due to an incident.

Apologies for any problems this causes you — we are working hard to resolve it. We will let you know when it’s fixed. Thanks for your patience!
Posted Jan 08, 2020 - 23:17 CET
This incident affected: Planday Web.